Canon Autozoom 814 electronic not working?

Technical talk about 8mm, Super8, 9.5mm, 16mm and 35mm ++ motion picture cameras.

Moderator: Andreas Wideroe

Post Reply
User avatar
D4rius
Posts: 1
Joined: Wed Sep 20, 2017 6:25 pm
Real name: Darius
Location: France
Contact:

Canon Autozoom 814 electronic not working?

Post by D4rius » Wed Sep 20, 2017 6:38 pm

Hello!
I am totally novice in shooting with movie cameras but I recently bought a Canon Autozoom 814 Electronic to jump in the world of super 8mm.
The thing is that when i bought my camera the battery chamber cover was missing. And when i insert 4 fresh AA batteries and try to hold them inserted in the chamber with my hands ,the needle in the battery check window is not moving at all, so my questions are:

1- Is the batttery chamber cover really essential for the camera to properly work? my idea is that it is just a plastic part that basically hold the batteries , no electronic connections there.


2-Do you think i could open it and try to see what's wrong inside the beast? or should i give up and buy another Canon 814?

if it is just a problem of metal connection i could easily fix that, maybe it has fell or whatever.

regards,
Darius

unsanity
Posts: 57
Joined: Wed Jul 20, 2011 9:29 pm
Real name: Julian Bell
Location: The Netherlands
Contact:

Re: Canon Autozoom 814 electronic not working?

Post by unsanity » Fri Sep 22, 2017 10:10 pm

Yes, the battery cover is necessary to complete the electrical connection between the batteries.

alexmuir
Posts: 33
Joined: Mon May 25, 2015 11:14 pm

Re: Canon Autozoom 814 electronic not working?

Post by alexmuir » Sat Sep 23, 2017 11:05 pm

I had one of these and I thought it took six AA cells? Four in the handle and another two in a compartment on the body near the film door. It wasn't obvious without instructions that you needed the other two. Maybe it was a different model 814?
Alex.


Sent from my iPhone using Tapatalk Pro

User avatar
Charlie Blackfield
Posts: 174
Joined: Mon Dec 22, 2008 9:09 pm
Real name: Klaus Huber
Location: Bradford-on-Avon / UK
Contact:

Re: Canon Autozoom 814 electronic not working?

Post by Charlie Blackfield » Mon Sep 25, 2017 3:22 pm

Alex, yours must have been a different model. I've got a Canon Autozoom 814 E, and it's definitely content with 4 AA batteries. As for the cover of the battery compartment, it's a pretty basic piece of plastic with a metal plate on the inside and a large screw. Shouldn't be impossible to find some DIY solution for it.

Charlie

Post Reply