Leicina Special Repair

Forum covering all aspects of small gauge cinematography! This is the main discussion forum.

Moderator: Andreas Wideroe

nikonr10
Posts: 385
Joined: Sat Dec 03, 2011 11:41 pm
Real name: Christopher Nigel

Re: Leicina Special Repair

Post by nikonr10 » Thu Apr 23, 2015 2:17 am

aj wrote:You cannot buy a defect camera from one, have it repaired somewhere else and then when it arrives with a fault have it sent back.
THis is kind of mixed up or not made clear by you ? so you got a camera from Ebay .de had the seller send it to the USA then you send the camera to Mr Ekhard of germany or was Mr Ekhard the seller from ebay .de ? Or just did A CLA ? , then sent it too you not working ? as it should ? ,
Why did you not get back in touch with Mr Ekhard if the camera was not working after you paid him to do CLA . ?
Still there alot of dollar's going into a camera not working , CLA / shipping . too / Germany / USA / Germany ?/ somewhere West coast / NYC ,

I really hope it all work's out for you ! , was a sad day when my fave beloved Leicina Special gave up her ghost .

silverhalide
Posts: 223
Joined: Tue Oct 01, 2013 7:57 pm
Real name: Dennis

Re: Leicina Special Repair

Post by silverhalide » Sat Apr 25, 2015 7:05 am

Hi Nikonr10,

I made a mistake when I wrote that earlier. I bought it on ebay.de and had it shipped to Ekhard along with another Leicina Special which I bought on ebay.de. He worked diligently on them, even locating a difficult-to-find motor, and shipped them to me in the US. When I made test films, I found that the meter was not working on one of them. I figured something happened during shipping.

So then, I sent the camera with the bad meter to a shop in the US, where it did not wind up being fixed. But now it's in the competent hands of DuAll.

Fingers crossed...

nikonr10
Posts: 385
Joined: Sat Dec 03, 2011 11:41 pm
Real name: Christopher Nigel

Re: Leicina Special Repair

Post by nikonr10 » Sat Apr 25, 2015 11:30 am

silverhalide wrote:Hi Nikonr10,

I made a mistake when I wrote that earlier. I bought it on ebay.de and had it shipped to Ekhard along with another Leicina Special which I bought on ebay.de. He worked diligently on them, even locating a difficult-to-find motor, and shipped them to me in the US. When I made test films, I found that the meter was not working on one of them. I figured something happened during shipping.

So then, I sent the camera with the bad meter to a shop in the US, where it did not wind up being fixed. But now it's in the competent hands of DuAll.

Fingers crossed...
Hello Sliverhalide ,
Would you say that Mr Ekhard did a good job and was his rate's reasonable , I too need one of then difficult to find motor's /bringing back one off my Leicina Special from the dead , There really are Special . working out if it's still worth going down that road ?

silverhalide
Posts: 223
Joined: Tue Oct 01, 2013 7:57 pm
Real name: Dennis

Re: Leicina Special Repair

Post by silverhalide » Sat Apr 25, 2015 3:11 pm

He was a nice guy and his work was fine.

nikonr10
Posts: 385
Joined: Sat Dec 03, 2011 11:41 pm
Real name: Christopher Nigel

Re: Leicina Special Repair

Post by nikonr10 » Sat Apr 25, 2015 7:27 pm

silverhalide wrote:He was a nice guy and his work was fine.
Silverhalide ,
Thank you ,will look into it/ will send him a email .

bradagua
Posts: 5
Joined: Tue May 30, 2017 5:28 pm
Real name: Bradley Hayman

Re: Leicina Special Repair

Post by bradagua » Sun Dec 17, 2017 1:58 pm

I was wondering if there’s any updates to the repair of your Leicina. I have one that was working yesterday afternoon but after loading it into my car for a couple hours in cold weather, it just stopped working.

Was wondering if the cold weather froze up something in the motor? Or maybe got bumped in transit? It seems very strange to suddenly stop like that. The meter seems to be working, the zoom and auto exposure both seem fine. Just the motor stopped responding

nikonr10
Posts: 385
Joined: Sat Dec 03, 2011 11:41 pm
Real name: Christopher Nigel

Re: Leicina Special Repair

Post by nikonr10 » Sun Dec 17, 2017 4:12 pm

bradagua wrote:
Sun Dec 17, 2017 1:58 pm
I was wondering if there’s any updates to the repair of your Leicina. I have one that was working yesterday afternoon but after loading it into my car for a couple hours in cold weather, it just stopped working.

Was wondering if the cold weather froze up something in the motor? Or maybe got bumped in transit? It seems very strange to suddenly stop like that. The meter seems to be working, the zoom and auto exposure both seem fine. Just the motor stopped responding
Try with a set of fresh Batterys after bringing camera to room temperature , cold weather & super 8 cameras do not mix so well as a rule .
There is a outside battery pack for the Leicina special which you can keep in you pocket etc .

The optional ST-1 Electronic Controller. Plugged into a special port on the Leicina camera body, the ST-1 gave the Leicina an intervalometer, sequence timer, sound synch tone generator and remote battery pack.

Hope this helps :D

Post Reply