Arri 16 SR Camera Problem. Troubleshooting.

Forum covering all aspects of small gauge cinematography! This is the main discussion forum.

Moderator: Andreas Wideroe

Post Reply
User avatar
Posts: 62
Joined: Sat Mar 03, 2007 5:59 pm
Location: Florida

Arri 16 SR Camera Problem. Troubleshooting.

Post by Tyler » Tue Dec 18, 2012 9:33 pm

I have an Arriflex 16 SR that has stopped working. When the red test button is pressed the motor rotates the shutter and the pull down claw engages. When the camera switch is moved from stop to ready the internal light meter turns on. So far everything functions normal.
However, when you flip the switch to run, the motor does not start and a red light comes on inside the view finder. The battery is fully charged tested it with a multi meter, and tried a different battery to be sure.
The owner’s manual says that a red light will come on in the view finder when the camera doesn’t have enough power to maintain a sync speed.

Has anyone else experienced this problem?
Does anyone know what the cause of this problem would be? Could it be that the voltage regulator is broken, or maybe the sync crystal is malfunctioning?
Does anyone know where a more detailed camera manual for this camera can be found? Like a troubleshooting or service and repair manual.

Senior member
Posts: 1945
Joined: Mon Sep 26, 2005 12:18 am
Real name: Will Montgomery
Location: Dallas, TX

Re: Arri 16 SR Camera Problem. Troubleshooting.

Post by Will2 » Wed Dec 19, 2012 9:53 pm

There are two switches on the sr's. They are tied to each other. One of the switches may not be engaging or broke. Pretty common problem. Not sure if that helps you actually fix it though.

Good news is there are plenty of Arri techs around still from Bernie up at Super16Inc. to any of the shops in LA or NYC. Switches shouldn't be very difficult or costly to fix.

Post Reply